TIBCO BusinessWorks Collaborator 5.3.0 has a known issue with Workflow Service Agent when we leave the "Priority Value" field balnk even with the "Priority Mode" disabled.

TIBCO BusinessWorks Collaborator 5.3.0 has a known issue with Workflow Service Agent when we leave the "Priority Value" field balnk even with the "Priority Mode" disabled.

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Article ID: KB0090377

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Updated On:

Products Versions
TIBCO BusinessWorks Collaborator -
Not Applicable -

Description

Description:
Symptoms
========
This is applicable for TIBCO BusnessWorks Collaborator 5.3 if you leave the "Priority Value" field in the Workflow Service Agent as blank. "Priority Value" is a new feature added in BWC 5.3. By default this will be set to 32767.

However, for project that are created in TIBCO BusinessWorks Collaborator 5.2 or earlier, this field will be set to blank and you will get the following error during project validation -
BW-WFSA-100035 "Priority value must be a number between -32768 and 32767"


Impact
======
You will get the following error during project validation -
BW-WFSA-100035 "Priority value must be a number between -32768 and 32767".

Workaround
==========
Assign a number between -32768 and 32767 to the "Priority Value" field.

Cause
=====
TIBCO BusinessWorks Collaborator 5.3 is NOT able to handle the empty value in the "Priority Value" field even with the "Prioirity Mode" set as disabled.

Resolution
==========
This will be addressed in the future release of TIBCO BusinessWorks Collaborator.
Symptoms:

Cause:

Issue/Introduction

TIBCO BusinessWorks Collaborator 5.3.0 has a known issue with Workflow Service Agent when we leave the "Priority Value" field balnk even with the "Priority Mode" disabled.