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Article ID: KB0090803
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Updated On:
Description
Description:
Symptom:
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The error noticed in your environment is because of the Siebel application disconnecting the JDB connections that have been idle for a period more than the ‘session idle timeout’ value.
Cause:
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The Siebel adapter interfaces with the Siebel application with the help of the Java Data Bean (JDB) interface provided by Siebel application. Each thread configured in the Siebel adapter creates a corresponding JDB connection with the Siebel application. If a thread were inactive for a period of time, the corresponding JDB connection would remain idle for that long. The Siebel Object Manager to which the adapter connects has a configurable parameter called ‘session idle timeout’ which decides the time for which this connection can remain idle without getting disconnected by the Siebel application.
Impact:
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Loss of Functionality
Adapter goes into reconnection and may result in loss of request.
Resolution:
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Typically our customers who have reported the issue, have avoided this behavior by:
1) Optimizing the thread count of the adapter instance such that it is enough to handle the performance during peak-load and no connections remain idle even during off peak-load.
2) Adjust the ‘session idle timeout to the optimum value’.
***The optimum values for thread count and ‘session idle timeout’ would have to be arrived at based on the load behavior in your environment. ***
Resolution steps -->
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Following step 1 given above would ensure that when the load is high, all the threads are active; but during hours when the load is less, some of the threads would remain idle, and these threads can be prevented from getting disconnected due to inactivity, by following step 2, i.e. adjusting the session idle timeout value appropriately; the steps for setting this value is explained below.
Since ‘session idle timeout’ is not specified in the adapter configuration but at the application side, you will need to contact Siebel administrator in order to specify a larger timeout value
However you could try using the siebel.properties file to set the JDB connection timeout value for connections created by the adapter with Siebel. A value in seconds has to be set for the parameter 'siebel.conmgr.sesstimeout'. Also once the siebel.properties file is configured, you would need to copy this file to the machine that runs the adapter and the path for the file has to be added to the system CLASSPATH environment variable. E.g. C:\siebel\siebel.preperties. Specifying the path for the file against the parameter tibco.env.CUSTOM_CP_EXT in the .tra file used by the adapter instance should also suffice.
***Setting the siebel.properties on client side may not be effective if the idle time out is already set to a non-default value on the Server side. ***
NOTE: Please note that, siebel.properties is not provided by the adapter and is part of Siebel installation. Siebel recommends any client connecting using Siebel JDB can use this file to set a few parameters. For more details please refer to the section 'Java Data Beam' in Siebel bookshelf. We are also attaching a copy of Siebel.properties file being used at our end.
Workaround:
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The workaround is to keep the threads active by performing dummy operations with Siebel periodically, i.e. please try to configure a service on the same session as is being used by the service that is timing out frequently. This can be configured to simply query the database for some record or invoke a simple workflow (a very simple one) at regular intervals and keep the connections from timing out.
Additional information -->
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1) We cannot provide an infinite value to the ‘session idle timeout’ parameter. We have logged a Change request 12-MOP1GL with Siebel asking to provide this feature. They do not recommend having an infinite timeout value though.
2) The behavior of JDB connections is defined by Siebel application itself. You can refer ‘Technical Note 388: How to Configure Siebel Object Manager (SOM) in Siebel 7’ to see Siebel’s recommendations on optimizing your object manager.
Symptoms:
Cause:
Issue/Introduction
TIBCO Adapter for Siebel logs timeout error, and tries reconnection.