Products | Versions |
---|---|
TIBCO Adapter for Remedy | - |
Not Applicable | - |
Description:
Symptoms
==========
The adapter often throws AR_RETURN_ERROR followed by a 'Entry does not exist in database' error.
Impact
======
Loss of Functionality.
Workaround
==========
Use the $Request ID$ field explictly as the adapter too looks for this.
Cause
======
This error often occurs when the Direct SQL statement provided with the adapter filter is modified. For instance in a particular case the customer had modified the SQL query to:
"insert into TIB_PENDING_NOTIFICATIONS (PENDING_ID,
RMDY_FORM_NAME, RMDY_ENTRY_ID, OPERATION_FLAG, PROCESSED_FLAG)
values (NOTIFICATION_ID.NEXTVAL, '$SCHEMA$' , '$Incident
Number$' , '$OPERATION$' , 'N')".
(Please note the $Incident Number$ instead of the $Request
ID$.
Resolution
==========
N/A since this is a configuration issue.
Symptoms:
Cause: