Products | Versions |
---|---|
TIBCO ActiveMatrix Adapter for Amdocs CRM | - |
Not Applicable | - |
Description:
Symptom
========
Clarify Adapter fails to process any service, where the custom wrapper class is being used. The below error is logged:-
ClarifyAdapterSub Error [Adapter] AEClarify-920018 "Subscription error. Subscription service ClarifyCaseServiceEndPoint listening on subject SUB.QUEUE failed due to Clarify application invocation error java.lang.NoSuchMethodError: com.tibco.adapter.clarify.ClarifyAppServer.getFormContext()Lcom/clarify/cbo/FormContext;.
Impact
=======
Loss of functionality
Cause
======
The 'FormContext' API call in ClarifyCRM v13.1 has been deprecated by Clarify and removed from TIBCO Adapter for Clarify 5.2.1. Thus, when projects are migrated from a previous version (prior to 5.2.1), the class is not found and an error occurs.
Workaround
===========
None
Resolution
===========
The 'FormContext' API call has been replaced with the ‘getBoContext’ API call in <clarifyAdapter_Home>\lib\adclyCRM.jar ->ClarifyAppServer.class. To resolve this error, do the following:
1. Replace the FormContext method call in the wrapper class used with BoContext
2. Recompile the wrapper class
3. Use the new wrapper class. Clarify had depracated the 'FormContext' API call in ClarifyCRM v13.1. Now, the same needs to be replaced by 'getBoContext' API call.
Symptoms:
Cause: