TIBCO BusinessEvents Performance Profiler does not populate any information in the profiler log.

TIBCO BusinessEvents Performance Profiler does not populate any information in the profiler log.

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Article ID: KB0086864

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Updated On:

Products Versions
TIBCO BusinessEvents Enterprise Edition -
Not Applicable -

Description

Resolution:
Description:
===========
TIBCO BusinessEvents does not populate the profiler logs.

Environment:
===========
TIBCO BusinessEvents  3.0.1

Symptoms:
=========
Profiler properties exist in TRA file but the logfile has not been created.

be.engine.profile.*.enable = true
be.engine.profile.*.file = /local/usr/be-engine/logs/
be.engine.profile.*.level = -1
be.engine.profile.*.duration = -1

Cause:
======
1). Improper log file name or the user does not have permission to write to the specified location.

2). There is a known issue in the initial BE 3.0.1 Hotfix releases

Resolution:
========
1). Verify the logfile settings.

        be.engine.profile.*.file = /local/usr/be-engine/logs/test.log

2). Use a positive number for the duration parameter.

        be.engine.profile.*.duration = 10

Issue/Introduction

TIBCO BusinessEvents Performance Profiler does not populate any information in the profiler log.