Running the TIBCO iProcess Engine 'swutil REDIRECTION' command may fail with an 'area locked' error.

Running the TIBCO iProcess Engine 'swutil REDIRECTION' command may fail with an 'area locked' error.

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Article ID: KB0094539

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Updated On:

Products Versions
TIBCO iProcess Engine (SQL) -
Not Applicable -

Description

Resolution:
Description:
============
Running the TIBCO iProcess Engine %SWDIR%\bin\swutil REDIRECTION command may fail with the following error:

Failed to lock redirection area (area locked)

Environment:
============
o All supported versions of the TIBCO iProcess Engine (iPE)
o All supported operating systems

Symptoms:
=========
Each time the swutil REDIRECTION command is executed, you will receive the 'area locked' message.

Cause:
======
If a previous swutil REDIRECTION attempt did not exit gracefully, a lock file will remain in the %SWDIR%/tsys directory.

Resolution:
===========
Delete the lock file named 'swpid' located in the in the %SWDIR%/tsys directory and retry the swutil REDIRECTION command.

Issue/Introduction

Running the TIBCO iProcess Engine 'swutil REDIRECTION' command may fail with an 'area locked' error.