JMS temp-queues are not closed although the JMS reply is successfully received by TIBCO IntegrationManager™.(IM)

JMS temp-queues are not closed although the JMS reply is successfully received by TIBCO IntegrationManager™.(IM)

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Article ID: KB0092679

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Updated On:

Products Versions
TIBCO IntegrationManager -
Not Applicable -

Description

Description:
TIBCO IntegrationManager™ (IM) 5.0.2 and TIBCO Enterprise Message Service™ (EMS) 4.3, 4.4.2 and 5.x versions. The following are the test results:

1). IM5.0.2 and EMS4.3  ->  temporary queues are created for every request/reply message and removed from the EMS server once the messages are consumed and when the consumer is closed.

2). IM5.0.2 and EMS 4.4.1/5.x -> temporary queues are not getting cleared from the EMS server. This behavior is expected from EMS 4.x and 5.x versions.

Symptoms:
Temporary queues are not deleted once the message is read from the temporary queue. Over a period of time the number of queues grows and and causes a performance issue. 

Cause:
There is a defect in the client version of EMS 4.4. The temporary queues are deleted by the requestor when there is no consumer or once the message is read. This issue was not seen in EMS 4.3.

Issue/Introduction

JMS temp-queues are not closed although the JMS reply is successfully received by TIBCO IntegrationManager™.(IM)

Resolution

With the EMS 4.3 client libraries, there are no issue where as with later EMS client libraries from EMS 4.4.x and onwards, the issue exists. Currently, IM5.0.2 code does not remove the temporary queues with versions of EMS 4.x, EMS 5.x or EMS 6.x .

A temporary workaround would be:

1). Bounce the IM engine and EMS server. 

2). Use Publish/Subscribe instead of Request/Reply mode.