Products | Versions |
---|---|
TIBCO Administrator | - |
Not Applicable | - |
Resolution:
Description:
============
The error, “Exception creating JMS connection: invalid name or password” is logged in the Administrator.log file. This only occurs a limited number of times on start up and does not appear to cause a problem.
Environment:
==========
All
Symptoms:
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The error message:
“Exception creating JMS connection: invalid name or password”
appears in the log file:
administrator.log
There are no other symptoms.
Cause:
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The EMS password stored in the database has not been updated by the domain utility. A change request has been submitted for this - 1-A6MUHM
Resolution:
=========
Try the following work around:
1). This workaround will update file AdministrationDomain.properties and AuthorizationDomain.properties and table AdMap, AuMap, and other <prefix>Map tables. Backup these files and tables before making the change.
2). Create a temporary password file (pwd.txt) in $TIBCO_HOME/tra/5.x/bin folder, and add one line such as the following:
pwd=#!changeme
(assuming the new EMS password is "changeme")
3). Run utility obfuscate to encrypt the password:
obfuscate pwd.txt
After that, the content in pwd.txt may look like as such:
pwd=#!ncsZF3wAqwls08V0gdyzZ+1n/sFRTuvOS2HBhJviHhY=
4). Update "notifier.ems.password" in AdministrationDomain.properties and AuthorizationDomain.properties with the new encrypted password string.
notifier.ems.password=\#\!ncsZF3wAqwls08V0gdyzZ+1n/sFRTuvOS2HBhJviHhY\=
Note: Character pound sign ('#'), equal sign ('=') and exclamation mark ('!') need to be escaped with a backslash ('\').
5) Update AdMpa, AuMap, and other <prefix>Map tables with below SQL statement like the following:
update ADMap set value = '#!ncsZF3wAqwls08V0gdyzZ+1n/sFRTuvOS2HBhJviHhY=' where MAPKEY='notifier.ems.password';
(no escape needed for character #, ! and =)
6). Commit the change, and restart the Admin server and Hawk agent.