Why do some agents appeare in "discovered" container after rebooting?

Why do some agents appeare in "discovered" container after rebooting?

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Article ID: KB0092028

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Updated On:

Products Versions
TIBCO Hawk -
Not Applicable -

Description

Resolution:
Description:
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Some of the agents appear in the “Discovered” container again after the rebooting of the agent machine, even though they were assigned to specified containers before. This usually happens when using a hdp file.

Environment:
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ALL

Symptoms:
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1). Assign the agent to one customized container in Hawk Display.
2). Reboot the agent machine.
3). The agent would appear in the “Discovered” container again in Hawk Display while the agent in customized container is still existing with “PURPLE” state and “XXXX Waiting for initial heartbeat.” tooltip.

Cause:
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This is generally caused by the network configuration change on the target agent machine. Hawk Display identifies agents by the combination of agent name, agent domain and Hawk domain. If the machine’s hostname changed or uses a dynamic IP, Hawk Display may treat the agent as a different agent.

Resolution:
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The machine has to be assigned a static IP. From Hawk Display, it is safe to remove the “purple” agents. If the network parameters do not change in the future, this error would not happen again.

Issue/Introduction

Why do some agents appeare in "discovered" container after rebooting?