BC does not set the permissions of a file correctly when the umask value of the underlying system changes.
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Article ID: KB0092394
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Updated On:
Products
Versions
TIBCO BusinessConnect
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Not Applicable
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Description
Description: Environment
TIBCO BusinessConnect 5.X
Symptoms:
On UNIX, the umask value was changed, but when the files are processed through BC, BC uses the previous umask setting. Restarting BC through the Administrator does not resolve the issue.
Cause:
The hawkagent has not been restarted after the umask setting was changed. Consequently, BC will start with the same umask settings as that which existed when the hawkagent started.
Resolution:
The user permission and umask setting are governed by the hawkagent that starts BC when starting from the Administrator. Check what the umask is of the user that starts the hawk agent in your environment, and make sure that the umask setting is correct for that user. Then, restart the hawkagent before restarting BC. Symptoms:
Cause:
Issue/Introduction
BC does not set the permissions of a file correctly when the umask value of the underlying system changes.