When using DomainUtilityCmd to create a new domain, it keeps reporting "port 8008 is in use".

When using DomainUtilityCmd to create a new domain, it keeps reporting "port 8008 is in use".

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Article ID: KB0088167

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Updated On:

Products Versions
TIBCO Runtime Agent (TRA) -
Not Applicable -

Description

Resolution:
Description:
When using DomainUtilityCmd to create a new TIBCO Administraion domain, it keeps reporting "port 8008 is in use", although you do not use the 8008 port in the CreateDomain.xml file. And even after modifying the Apache Tomcat port number, the error persists. When checking the port 8008, you may find that no application is using it.

Environment:
All

Symptoms:
You can find "port 8008 is in use" error in the console and domainutiltycmd.log file.

Cause:
You have specified port 8008 as “shutdown” port or “http” port in one of your existing TIBCO Administration domains. The port 8008 will be used by DomainUtilityCmd when creating a domain. So when it detects this port is used by a TIBCO Administration domain, the "port 8008 is in use" error will be generated.

Resolution:
There are two workarounds here.
1) You can find out which TIBCO Administration domain is using the port 8008 by checking &ltTIBCO_Home>/administrator/domain/&ltdomain_name>/tomcat/conf/server.xml file. Then use DomainUtility/DomainUtilityCmd to modify the TIBCO Administration domain transport.
2) You can try to modify your CreateDomain.xml file and add an element “&ltApacheWarpConnectorPort&gtPort_Number</ApacheWarpConnectorPort>” under the &ltshutdownport> element.

Issue/Introduction

When using DomainUtilityCmd to create a new domain, it keeps reporting "port 8008 is in use".