When deploying a Business Events application from the Administrator GUI, the following error is reported: ===================com.tibco.be.deployment.tsm.TSMBEEngineDeployActions===================

When deploying a Business Events application from the Administrator GUI, the following error is reported: ===================com.tibco.be.deployment.tsm.TSMBEEngineDeployActions===================

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Article ID: KB0085281

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Updated On:

Products Versions
TIBCO Administrator -
Not Applicable -

Description

Resolution:
Description:
========
The error is thrown after clicking on the Deploy button in the Administrator GUI.

Environment:
=========
All

Cause:
=====

The error is due to the Administrator not correctly loading the Business Events plug-in. There are multiple possible causes.

  • Hawkagent on the BE Machine is locked and not able to upload the BE plug-in due to .installregistrylock or .installregistrylck and .installerregistrysync files existing under the <TIBCO_HOME> dir . Yyou need to remove these .lck and .sync files and restart Hawkagent refer solution KB:38416 :Scenario 1.
  • Sometime there is an RVD communication issue between the client machines (BE Machine) and the Admin machine while registering the BE plug-in .



Resolution:
========

Copy the Business Events plug-in that is: “be-admin.jar” file from <be-home>/3.x/admin-plugins folder to the <tra-home>/lib folder and restart Administrator and the Hawkagent.

Issue/Introduction

When deploying a Business Events application from the Administrator GUI, the following error is reported: ===================com.tibco.be.deployment.tsm.TSMBEEngineDeployActions===================

Additional Information

KB:38416