Special characters cannot be identified and handled properly by TIBCO Adapter(TM) for LDAP

Special characters cannot be identified and handled properly by TIBCO Adapter(TM) for LDAP

book

Article ID: KB0085712

calendar_today

Updated On:

Products Versions
TIBCO ActiveMatrix BusinessWorks Plug-in for LDAP -
Not Applicable -

Description

Resolution:
Description:
============
An issue can be found when LDAP Adapter is handling message that contains special characters. The special characters cannot be identified properly by LDAP Adapter.

Environment:
===========
TIBCO Adapter for LDAP 5.4.0
All supported operation systems
All supported LDAP Server types

Symptoms:
========
Using LDAP Adapter to create a new object in LDAP Server with some special characters used in attributes; though the new object could be created successfully in LDAP Server, but all the special characters could not be shown properly.

Cause:
=====
This issue could be caused by the Adapter Encoding configuration; by default, the Adapter Encoding for LDAP Adapter is set as "ASCII", which could not handle the special characters.

Resolution:
==========
This issue could be resolved by setting Adapter Encoding to UTF8.

References:
==========
The difference between TIBCO Message Encoding attribute and Adapter Encoding attribute configurations at design-time: -
1. TIBCO Message Encoding attribute is mainly used for specifying the encoding of the messages sent to or received from TIBCO Bus; it determines the message encoding type for the communication between TIBCO Bus and our Adapters.
2. Adapter encoding attribute is used for specifying the encoding type for the communication between our Adapters and Target System. Each adapter should have different use for this attribute; it depends on the requirement of Target System.

Issue/Introduction

Special characters cannot be identified and handled properly by TIBCO Adapter(TM) for LDAP