What is the cause of the LICENSE.EXPIRE advisory message?

What is the cause of the LICENSE.EXPIRE advisory message?

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Article ID: KB0085702

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Updated On:

Products Versions
TIBCO Rendezvous -
Not Applicable -

Description

Resolution:
Description
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The LICENSE.EXPIRE advisory message is displayed upon TIBCO Rendezvous (RV/RVD) start up. What causes this message to be displayed and how can it be suppressed?

Environment
==========

All

Symptoms
==========

The following advisory shows up in the application log:

2010-03-02 15:38:33 RV: TIB/Rendezvous Error Not Handled by Process:
{ADV_CLASS="WARN" ADV_SOURCE="SYSTEM" ADV_NAME="LICENSE.EXPIRE" ADV_DESC="The license will expire" expiretime=2010-03-02 21:48:18Z host="10.20.30.40"}

Cause
=====

Each Rendezvous daemon process requires a valid license.  Some licenses are valid for only a limited time.  These messages indicate either expiration or pending expiration of a license.

As a Warning advisory, the _RV.WARN.SYSTEM.LICENSE.EXPIRE message indicates that the license will expire soon.  Every Rendezvous daemon that depends on that license presents this warning message to each of its client transports.

As an Error advisory, the _RV.ERROR.SYSTEM.LICENSE.EXPIRE message indicates that the license has already expired.  Every affected Rendezvous daemon stops servicing its client programs and presents this error message to each client transport.

Resolution
==========

Things to check:

Do you have a valid RV/RVD license?


1. If you have a valid license, there is something wrong with your configuration; please check the following:

(a). The ticket file should be named "tibrv.tkt" and should be placed in the directory [TIBCO/RV_HOME]\bin .

(b). Confirm that the PATH environment variable contains the [TIBCO/RV_HOME]\bin directory or the directory that contains the tibrv.tkt file.  It is possible that the PATH is not correctly set; please ensure that the execution path of each user includes the directory that contains the "tibrv.tkt" file.

(c). Note that daemons read a license ticket file only during start up.  The daemon(s) must be cycled once a valid license ticket has been installed with the correct settings as stated above.

2. If you do not have a valid license, please verify if you are able to download the tibrv.tkt file from the TIBCO download site at  http://download.tibco.com. If you cannot download the tibrv.tkt file, please open a Service Request (SR) so that TIBCO Support can assist in obtaining the license file.

3. If you still have problems and need further assistance, please send the following information for further investigation to Tibco Support:

(a). System path variable setting.

(b). Run RVD and submit the entire output for review.


The output should resemble the following which details the ticket file in use and its location.  Please submit this tibrv.tkt as an attachment to your case.  


=======================================================================
C:\rvd
TIB/Rendezvous daemon
Copyright 1994-2007 by TIBCO Software Inc.
All rights reserved.

Version 8.0.0 V38 11/3/2007
2008-04-02 14:13:22 rvd: Command line: rvd
2008-04-02 14:13:22 rvd: Hostname: myhost
2008-04-02 14:13:22 rvd: Hostname IP address: 10.20.30.50
2008-04-02 14:13:22 rvd: Detected IP interface: 10.20.30.50 (IP00)
2008-04-02 14:13:22 rvd: Detected IP interface: 127.0.0.1 (loopback)
2008-04-02 14:13:22 rvd: Using ticket file C:\tibco\TIBRV\8.0/bin\tibrv.tkt
2008-04-02 14:13:22 rvd: Http interface - http://myhostname.na.tibco.com:7580/
=======================================================================

In the example above the tibrv.tkt file located in the C:\tibco\TIBRV\8.0\bin directory.

(c). Go to the rvd http interface "General Information" page, and capture/submit a screen snapshot.

Note: Use “http://myhostname.na.tibco.com:7580” to connect to the rvd http interface.

Keywords/Tags:
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tibrv.tk, LICENSE.EXPIRE advisory message

Issue/Introduction

What is the cause of the LICENSE.EXPIRE advisory message?