Not able to start Netrics on HPUX/Unix

Not able to start Netrics on HPUX/Unix

book

Article ID: KB0085650

calendar_today

Updated On:

Products Versions
TIBCO Collaborative Information Manager -
Not Applicable -

Description

Resolution:
Not able to start Netrics on HPUX/Unix

Environment:

TIBCO Product name and version: TIBCO Collaborative Information Manager 8.X.X
Operating System(s): All Operating Systems

Symptoms:
"bash" shell error as below is thrown when starting netrics.
$ ./netricsServer.sh -startServer

interpreter "/bin/bash" not found
file link resolves to "/usr/bin/bash"
ksh: ./netricsServer.sh: not found

Cause:
Netrics startup script by default tries to use /bin/bash shell. If that shell is not found exception would be thrown.

Resolution:
Change the first line of the file netricsServer.sh to be #!/bin/sh and try to execute the script again.

Else execute following command "which sh" and have the output of the command as first line of the script

References:

None

Issue/Introduction

Not able to start Netrics on HPUX/Unix