Why multiple entries in productlog/History for same version of the record.

Why multiple entries in productlog/History for same version of the record.

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Article ID: KB0085792

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Updated On:

Products Versions
TIBCO Collaborative Information Manager -
Not Applicable -

Description

Resolution:
Why multiple entries in productlog/History for same version of the record.

Environment:

TIBCO Product name and version: TIBCO Collaborative Information Manager 7.X.X and 8.X.X
Operating System(s): All Operating Systems

Symptoms:

Cause:
For example:
1> You have a record with with PRODUCTID, PRODUCTIDEXT,UOM and SHORTDESC as test,test,test and test with version V1.
2> You receive a Inbound JMS message with RECORDTYPE as 'metal' for the above record. (Version V2 would be created)
3> Now you receive another message for the same above record with UOM as test.(New version would not be created, because there is no change in the data that is being processed. for the record UOM was already 'test' existing in the master catalog.) So because of this reason you would still see Version V2 for the new event.

Resolution:
To increment the version everytime you process the record, it is required to have a change in the data.


References:

None:

Issue/Introduction

Why multiple entries in productlog/History for same version of the record.