TIBCO Business Events engine does not handle the spanish characters properly

TIBCO Business Events engine does not handle the spanish characters properly

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Article ID: KB0086329

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Updated On:

Products Versions
TIBCO BusinessEvents Enterprise Edition -
Not Applicable -

Description

Resolution:
Description:
============

The spanish characters in the incoming event data are incorrectly interpreted by the Business Events engines.

Environment:
============

   o TIBCO BusinessEvents 3.0.1
   o All OS
  
Symptoms:
=========

The spanish characters will be shown as '??' (one character is replaced with two question marks)

Cause:
======

This happens because of incorrect JVM encoding setting.
The type of encoding used by BusinessEvents engine (which is a JVM) depends on the system locale/encoding settings.

Resolution:
===========

ISO 8859 character set covers the spanish characters. If the system locale/encoding settings are different than ISO8859_1 then using the below property to set the JVM file encoding to ISO8859_1 in the BE engine tra file fixes the issue.

java.property.file.encoding=ISO8859_1

Issue/Introduction

TIBCO Business Events engine does not handle the spanish characters properly