Recurring errors in TIBCO iProcess Objects Server (iPOS) log indicating a view could not be found.

Recurring errors in TIBCO iProcess Objects Server (iPOS) log indicating a view could not be found.

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Article ID: KB0088891

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Updated On:

Products Versions
TIBCO iProcess Workspace (Browser) -
Not Applicable -

Description

Resolution:
Environment:
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All environments and the database products MSSQL, Oracle and DB2, running TIBCO iProcess Engine and TIBCO iProcess Workspace (Browser).

Symptoms:
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A message similar to the following gets written repeatedly to the $SWDIR/logs/swentobjsv01.log at regular intervals.

24989|00000018|04/15/2010 10:14:04.525|00010000|ERROR|could not find view ID, vid = e090;SUSPENSION@myipenode|R;R;U;L;2969856;14647437
24989|00000018|04/15/2010 10:14:04.525|00010000|ERROR|get_wqs_session() returned an error, qlistsh = 0, err=-201
24989|00000018|04/15/2010 10:14:04.525|00010000|ERROR|qquery_win_setup() returned an error, queuename = SUSPENSION@myipenode, rc = -201
24989|00000018|04/15/2010 10:14:04.525|00010000|ERROR|process_transaction() failed, rc=-201 Message Code(QQW)


Cause:
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If the WQSAbandonPeriod attribute for the TIBCO iProcess Objects Server (iPOS)  is set to less than the auto-refresh period in the TIBCO iProcess Workspace (Browser), the iPOS will destroy the view before the auto-refresh period expires. By default, the WQSAbandonPeriod is 900 seconds and the auto-refresh period is 60 seconds. Under normal circumstances these settings should not cause the problem. However, to reduce the memory footprint when using a large number of iPOS, it is often advisable to reduce the WQSAbandonPeriod.

There may be a number of reasons why a view could not be found, but a recurring message at a regular time interval could be indicative of this particular problem. The time interval between messages will be whatever value has been set for the auto-refresh period.


Resolution:
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When changing the value of the WQSAbandonPeriod for an iPOS ensure it is greater than the auto-refresh value set for the TIBCO iProcess Workspace (Browser).

Issue/Introduction

Recurring errors in TIBCO iProcess Objects Server (iPOS) log indicating a view could not be found.