Products | Versions |
---|---|
TIBCO ActiveMatrix Policy Manager | - |
Not Applicable | - |
Resolution:
Description:
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Having too many criteria (more than 10 ‘Apply To’ criteria or more than 2 ‘Exclude’ criteria) for a policy can sometimes cause Policy Manager console to become unresponsive.
Environment:
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• ALL
Symptoms:
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Policy Manager console will be slow to respond or completely unresponsive. At the same time in the background you will see that some database queries from Policy Manager database user are taking long to execute.
Cause:
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Having too many criteria for a policy results in database queries which take long time to execute and in turn affects the PM response time.
Resolution:
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One way of applying policy to an endpoint is by selecting the option 'Use Existing Policy'. Every time a policy is applied to an endpoint this way a new entry gets added to the criteria for that policy. The same applies to 'Exclude Endpoint from Policy'/'Exclude Service from Policy' options as well.
To limit the number of criteria you may consider the following options when applying policies -
If a policy is going to be applicable to all endpoints select the default criterion - Apply to all services.
If the policy is going to be applicable to only a subset of services then specify a criterion based on some attribute that is common to these services (URL, endpoint name etc.)
If you cannot find anything common for the services to which you want to apply a policy you can create a custom attribute and assign it to these services. Then you should come up with a criterion based on this custom attribute.