On starting the BusinessEvents(BE) Engine after enabling the JMX remote authentication,a Password file error is thrown.

book

Article ID: KB0088024

calendar_today

Updated On:

Products Versions
TIBCO BusinessEvents Enterprise Edition -
Not Applicable -

Description

Resolution:
Description:
============
On starting the BusinessEvents(BE) Engine after enabling the JMX remote authentication,  a Password file error is thrown.


Environment:
==========
TIBCO BusinessEvents 3.0.1


Symptoms:
=========
BE Engine throws the following error -

  Error: Password file read access must be restricted

Cause:
=====
For security reasons, the system checks that the password file used in authenticatio is only readable or writeable by the owner and exits with an error if not.

Resolution:
=========
Change the Permission for the file used in authentication to 600 by running the following command:

        > chmod 600 jmxremote.password


References:
==========
http://java.sun.com/j2se/1.5.0/docs/guide/management/agent.html#PasswordAccessFiles

Issue/Introduction

On starting the BusinessEvents(BE) Engine after enabling the JMX remote authentication,a Password file error is thrown.