Umlauts not displayed correctly in the TIBCO iProcess Workspace clients after upgrading the TIBCO iProcess Engine.

Umlauts not displayed correctly in the TIBCO iProcess Workspace clients after upgrading the TIBCO iProcess Engine.

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Article ID: KB0088785

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Updated On:

Products Versions
TIBCO iProcess Engine (Oracle) -
Not Applicable -

Description

Resolution:
Description:
===========
Umlauts not displayed correctly, for example in the Work Queue Name Description, in the TIBCO iProcess Workspace clients after upgrading the TIBCO iProcess Engine (iPE).

Environment:
===========
  o TIBCO iProcess Engine (Oracle) 11.1.x
  o All supported Oracle platforms
  o All supported versions of Oracle
  o TIBCO iProcess Workspace (Browser)
  o TIBCO iProcess Workspace (Windows)

Symptoms:
=========
Umlauts are not displayed correctly when viewing work queues and work items after upgrading the TIBCO iProcess Engine.

Cause:
======
As part of the upgrade installation instructions the SWDIR/swdefs file required updating to the new version, where SWDIR is the iPE installation directory. The installation instructions were incorrect and the following change was made:

from:
i11.1-o(0.3)
to:
i11.1(0.3.5)

The -o is missing in the version number. Because of this some processes will not load the NLS_LANG settings.

Resolution:
========
Change version in the swdefs file to include "-o"
i11.1-o(0.3.5)

Issue/Introduction

Umlauts not displayed correctly in the TIBCO iProcess Workspace clients after upgrading the TIBCO iProcess Engine.