BusinessConnect Administrator interface does not work correctly on a laptop.

BusinessConnect Administrator interface does not work correctly on a laptop.

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Article ID: KB0088709

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Updated On:

Products Versions
TIBCO BusinessConnect -
Not Applicable -

Description

Resolution:
Description:
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I use BusinessConnect (BC) on my laptop.  Frequently, I can not get the BusinessConnect server to start correctly in my environment, especially when I am switching locations with the laptop or using a VPN.  The only way to fix this is to reboot the laptop.  How can I avoid this?
 
Environment:
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BusinessConnect all versions
TRA 5.5.0 and above
Administrator 5.4.0 and above.
Windows operating system

Cause:
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BC can not start correctly because the RVDs that it is using for communication stop functioning when switching network environments.
 
Resolution:
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To avoid rebooting the machine do the following:

1). Shut down all TIBCO components ( BC engine, Administrator, Hawk, etc.).  Use the Windows Service Manager to shut down any TIBCO components that are running as Windows services.

2). Bring up the Windows Task Manager and find any remaining rvd.exe programs that are running and terminate them.  Make sure that all rvd's terminate.  If one keeps starting, there is still one TIBCO component running, possibly the tibhawkhma.exe agent.  Make sure it is terminated and then terminate all other rvd's.

3). Restart all TIBCO components.

4.) Your system should now be able to start BC correctly.

Issue/Introduction

BusinessConnect Administrator interface does not work correctly on a laptop.