Newly added roles are not appearing in the role list of the Create User screen in the TIBCO Collaborative Information Manager (CIM) User Interface.

Newly added roles are not appearing in the role list of the Create User screen in the TIBCO Collaborative Information Manager (CIM) User Interface.

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Article ID: KB0088247

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Updated On:

Products Versions
TIBCO Collaborative Information Manager -
Not Applicable -

Description

Resolution:
Description:
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After adding roles as indicated in the Customization Guide those roles are seen in the CIM User Interface (Administration --> Roles menu) but the same roles do not appear in the Available Roles section in the "Create User" screen.

Environment:
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TIBCO Product name and version: TIBCO Collaborative Information Manager 8.0.x
Operating System(s): All Operating Systems

Symptoms:
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See the description.

Cause:
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This generally happens when the ORGANIZATIONTYPE is set incorrectly for the newly created roles in the ROLE table.

Resolution:
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In order to resolve this issue, set the ORGANIZATIONTYPE correctly for all the newly added roles in the ROLE table.  To find out the correct ORGANIZATIONTYPE use the following SQL:

SELECT TYPE from ORGANIZATION where NAME = '&ltnameOfEnterprise>';

Here &ltnameOfEnterprise> is the Enterprise Name where you are adding the new roles.

Attachments:
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None

References:
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None

Keywords
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role, create user, ORGANIZATIONTYPE

Issue/Introduction

Newly added roles are not appearing in the role list of the Create User screen in the TIBCO Collaborative Information Manager (CIM) User Interface.