Why are the BusinessConnect (BC) trace/log files not created or not rolling over when the BC engine is running?

Why are the BusinessConnect (BC) trace/log files not created or not rolling over when the BC engine is running?

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Article ID: KB0088763

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Updated On:

Products Versions
TIBCO BusinessConnect -
Not Applicable -

Description

Resolution:
Description:
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I have noticed that when BC engine is running, the BC trace/log files are not created or rolling out to new log files.

Environment:
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BusinessConnect all versions


Symptoms:
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1. The BC engine is running fine and all transactions are successfully processed and audit logged in the database. However, in the BC application/logs, the BC trace/log file is not created.

2. BC is successfully processing and audit logging the transactions in the database, but the BC trace/log file is continuously growing even though a file size limit, such as 20000 (Max Log File Size (KB)), is set in the Administrator for Interior/single server.

Cause:
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This issue could happen if the communication between BC and Hawk is not working. As RV is the communication medium between BC and Hawk, it may happen if there any existing RV/Network related issues.

Resolution:
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First stop BC and Hawk. Then start Hawk first and then start the BC engine next. This may resolve the issue.

If not, you can run the tibrvlisten using the following command, capture the output and send submit it to TIBCO Support for review.

tibrvlisten "_RV.>" "_RVFT.>" "_RVCM.>" "_RVCMQ.>" > RV_Output.txt

Issue/Introduction

Why are the BusinessConnect (BC) trace/log files not created or not rolling over when the BC engine is running?