TIBCO BusinessWorks(TM) Salesforce.com Plug-in could not connect to Salesforce.com server in the case of using TIBCO Runtime Agent 5.6.2 and updating the TIBCO JVM Environment Path to JRE 1.6.0

TIBCO BusinessWorks(TM) Salesforce.com Plug-in could not connect to Salesforce.com server in the case of using TIBCO Runtime Agent 5.6.2 and updating the TIBCO JVM Environment Path to JRE 1.6.0

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Article ID: KB0088126

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Updated On:

Products Versions
TIBCO ActiveMatrix BusinessWorks Plug-in for Salesforce.com -
Not Applicable -

Description

Resolution:
Description:
============
When using TIBCO Runtime Agent 5.6.2 and updating the TIBCO JVM Environment Path to JRE 1.6.0, TIBCO BusinessWorks(TM) Salesforce.com Plug-in could not connect to Salesforce.com server.

Environment:
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All supported versions of TIBCO BusinessWorks(TM) Salesforce.com Plug-in
TIBCO Runtime Agent 5.6.2 with JRE 1.6.0 specified

Symptoms:
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The follwing error can be observed while trying to connect to Salesforce.com server in both Plug-in design-time and runtime: - Trampoline error: Salesforce Connection busyLogin "java.lang.reflect.InvocationTargetException".

Cause:
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This is caused by a known issue of TRA 5.6.2: - TIBCrypt SSL vendor conflicts with JRE 1.6 version.

Resolution:
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This issue has been fixed by TRA Crypto 2.14.1 Hotfix 1, which is bundled with TIBCO TRA 5.6.2 hot fix 1.

So in order to resolve this issue, we can install TIBCO TRA 5.6.2 hot fix 1 in the environment.

Issue/Introduction

TIBCO BusinessWorks(TM) Salesforce.com Plug-in could not connect to Salesforce.com server in the case of using TIBCO Runtime Agent 5.6.2 and updating the TIBCO JVM Environment Path to JRE 1.6.0