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Article ID: KB0088188
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Updated On:
Description
Description:
Version #2: Reissued September 2, 2010
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Customers installing or upgrading to "TIBCO Object Service Broker for Open Systems 5.2.0", should be aware of omissions in the Release Notes and TIBCO® Object Service Broker for Open Systems Installing and Operating Software Release 5.2.0 manual.
The TIBCO Object Service Broker for Open Systems Installer: Java
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The TIBCO Object Service Broker for Open Systems 5.2.0 installer requires that a formal (JavaSoft) JDK be pre-installed.
1) Windows Platform:
Java environments installed for other products may not be found or be acceptable to the installer. Installing a complete JDK will resolve this issue.
-obtainable from:
<http://www.oracle.com/technetwork/java/javase/downloads/jdk6-jsp-136632.html>
Setting JAVA_HOME for Windows is not necessary if the formal JDK is installed.
2) Solaris Platform:
If a JAVA JRE version 1.5 or higher is installed and JAVA_HOME is correctly set, the JRE referenced by JAVA_HOME is used. If no JRE is installed and/or JAVA_HOME is incorrectly set or not set at all, the installers use their own JRE that is bundled with the Object Service Broker for Open Systems.
The TIBCO Object Service Broker SDK Clients Installer: Windows .NET / J#
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The SDK Clients Installer is an optional process. On Windows, the SDK Client is used to support:
• TIBCO Object Integration Gateway: J2EE for Windows
• TIBCO Object Integration Gateway COM, .NET and ODBC Adapter components.
There are two SDK installer issues concerning the supported Windows platforms. The Release Notes and TIBCO® Object Service Broker for Open Systems Installing and Operating Software Release 5.2.0 documents should have contained a statement advising that if you are using the SDK Clients installer on Windows, then you require the following prerequisite software for supported Microsoft Windows platforms:
1) Microsoft .NET Framework 3.0 Redistributable Package (or later version)
-obtainable from:
<http://www.microsoft.com/downloads/details.aspx?FamilyID=10cc340b-f857-4a14-83f5-25634c3bf043&displaylang=en>
2) Microsoft Visual J# Version 2.0 Redistributable Package
-obtainable from:
<http://www.microsoft.com/downloads/details.aspx?familyid=f72c74b3-ed0e-4af8-ae63-2f0e42501be1&displaylang=en>
If you have older versions of the software installed, the SDK Installer may report erroneously that no versions of the required software was found when in fact the wrong version was discovered. Installing the correct software levels of the prerequisite software will correct this issue.
The Enterprise Message Service (EMS) interface:
===============================================
If you plan to use the Enterprise Message Service (EMS) interface, customers running on supported Windows or Solaris platforms require the TIBCO Enterprise Message Service (EMS) Release 5.1.x 32-bit client binaries.
Environment:
============
All supported Windows and Solaris platforms where "TIBCO Object Service Broker for Open Systems 5.2.0" and/or "TIBCO Object Service Broker SDK Clients" are being installed.
Symptoms:
=========
If the formal (JavaSoft) JDK is not installed, the TIBCO Object Service Broker for Open Systems 5.2.0 installers will report:
"ERROR : OSB Requires JAVA at minimum 1.5 level to run various client programs. Set JAVA_HOME and try again."
or
"Error - JAVA_HOME not set."
and the installer will fail.
If the prerequisite Microsoft software is not installed for the SDK Clients Windows installer, the message:
"No versions of Microsoft Visual j# redistributables found on this machine - Cannot proceed with SDK Clients upgrade launching"
will be issued and the installer will fail.
Cause:
======
The prerequisite software is not installed. See details above.
Resolution:
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Acquire the prerequisite software using the URLs provided above. Once the software is installed, retry the installer.
References:
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TIBCO Product Documentation:
TIBCO® Object Service Broker for Open Systems Installing and Operating Software Release 5.2.0
TIBCO® Object Service Broker for Open Systems 5.2.0: Release Notes
Microsoft Prerequisite Software links:
<http://www.microsoft.com/downloads/details.aspx?FamilyID=10cc340b-f857-4a14-83f5-25634c3bf043&displaylang=en>
<http://www.microsoft.com/downloads/details.aspx?familyid=f72c74b3-ed0e-4af8-ae63-2f0e42501be1&displaylang=en>
Oracle Prerequisite Software links:
<http://www.oracle.com/technetwork/java/javase/downloads/jdk6-jsp-136632.html>
History:
========
August 25, 2010: -Reissued to correct URL references and minor formating issues.
September 2, 2010: -Reissued to include more specific information including Java and EMS issues.
Symptoms:
Cause:
Issue/Introduction
Prerequisite software information is missing for the Open Systems installer which may lead to an install or upgrade failure.