How to address an increasing Tuxedo session created by adapter?

How to address an increasing Tuxedo session created by adapter?

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Article ID: KB0086290

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Updated On:

Products Versions
TIBCO ActiveMatrix BusinessWorks Plug-in for Oracle Tuxedo -
Not Applicable -

Description

Resolution:
Description:
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TIBCO Adapter (TM) for Tuxedo fails to release a connection which leads to increasing session on the Tuxedo server side.


Environment:
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All supported versions of TIBCO Adapter (TM) for Tuxedo.

Symptoms:
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When the adapter connects to Tuxedo 8.0 , there may be a releasing connection error under some cases, such as a broken network connection. With such an error an increasing session on the Tuxedo server side may be seen until the server crashes.

Cause:
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It is one Oracle defect that adapter couldn’t release connection with Tuxedo API.

Resolution:
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In order to resolve this issue, the customer needs to add the –K parameter in the UBB file to avoid increasing the session count.  This parameter would be used to check the connection availability and the Tuxedo server would clear the invalid connection. For more detail about the  –K parameter, please refer to Oracle documentation.

Issue/Introduction

How to address an increasing Tuxedo session created by adapter?