Unable to start the TIBCO BusinessEvents engine after a successful deployment using TIBCO Administrator.
Welcome to "KB Articles"
Unable to start the TIBCO BusinessEvents engine after a successful deployment using TIBCO Administrator.
book
Article ID: KB0085984
calendar_today
Updated On: 01-14-2017
Products
Versions
TIBCO BusinessEvents Enterprise Edition
-
Not Applicable
-
Description
Resolution:
Description:
============
Starting TIBCO BusinessEvents (BE) engine from TIBCO Administrator throws java.lang.ClassNotFoundException
Environment:
==========
o BE 3.0.x
o All Operating Systems
Symptoms:
=========
Unable to start the TIBCO BusinessEvents engine after a successful deployment using TIBCO Administrator. The BE engine log shows the following exception.
Error [main] - java.lang.ClassNotFoundException: be.gen.ExternalEvent$0020Archive.BE$$Actions$Startup Error [main] - at java.lang.ClassLoader.findClass(ClassLoader.java:358) Error [main] - at com.tibco.cep.runtime.service.loader.ClassManager.findClass(ClassManager.java:98)
Cause:
=====
This issue generally happens if you have modified the filteredfiles.txt in your <trahome>/lib/ directory, to filter out files with extensions .jar. As this file filteredfiles.txt file contains a list of file patterns which should be hidden, if it has the ,jar file listed in here then the BE class files will be ignored which causes this issue.
Resolution:
=========
Remove the entry .jar from the filteredfiles.txt in your <trahome>/lib/ directory. Undeploy and redeploy the BE application in your TIBCO Administrator.
Issue/Introduction
Unable to start the TIBCO BusinessEvents engine after a successful deployment using TIBCO Administrator.