Products | Versions |
---|---|
TIBCO BusinessConnect EDI Protocol HIPAA Edition Powered by Instream | - |
Not Applicable | - |
Resolution:
Description:
============
BusinessConnect (BC) errors out with “Transaction not found” when generating a 005010X231/999 acknowledgement response to an inbound 005010X279/270R synchronous request.
Environment:
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BusinessConnect EDI Protocol HIPAA Edition 5.2.0 and above
Symptoms:
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BC is failing to send an 005010X231/999 ACK out for an inbound 005010X279/270R sync request.
Cause:
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The reason for this behavior is as follows:
1). The HIPPA standards define that the group number 231 is fixed for all 999 transactions should be returned as a synchronous acknowledgement for any version of request no matter what the inbound group level transaction is.
2). BusinessConnect will generate a 231/999 acknowledgement for an inbound 279/270R (for any inbound group version).
3). When generating an acknowledgement, BusinessConnect looks up the acknowledgement guideline or error severity file using the original operation ID group version rather than the operation ID group version for the 999. Thus, it will try to find a 5010X231/270R to generate the acknowledgement rather than a 5010X279/270R transaction.
4). BC will then report, “Transaction not found”.
Resolution:
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Import the standard 005010-HIPAA.csx file that is provided in the $BC_HOME/protocols/edi/samples/interfaces directory. If you would like to define the transaction manually, configure a 270R operation for 005010X231/270R. Export the 270R operation from 005010X279/270R in the Operations Editor and import it under group 231. This behavior is applicable to a HIPAA transaction only.