When processing an inbound EDIFACT document the error, "contains characters not listed in the allowed character set", is seen even though the text content looks correct.What is the cause of thie error message?

When processing an inbound EDIFACT document the error, "contains characters not listed in the allowed character set", is seen even though the text content looks correct.What is the cause of thie error message?

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Article ID: KB0086122

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Updated On:

Products Versions
TIBCO BusinessConnect EDI Protocol Powered by Instream -
Not Applicable -

Description

Resolution:
Description:
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When processing an inbound EDIFACT document the error, "contains characters not listed in the allowed character set", is seen even though the text content looks correct.  What is the cause of thie error message?

Environment:
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BusinessConnect EDI Protocol 5.2.0 and above

Cause:
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The character set used in an EDIFACT document is defined by the "UNO*" segment in the Interchange header.  The most common example of the reported problem is when BusinessConnect tries to process an inbound EDIFACT document that uses a "UNOA" value for the character set (which does not include lower case characters) which contains lower case characters in the transaction body.


Resolution:
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Make sure that your trading partner is aware of the EDIFACT standard regarding proper character sets.

If your trading partner can not change the header, you can define a customer character set for the EDIFACT transaction that includes the characters you desire.  Check the EDI User's Guide under the Appendix "Creating User Specific Character Sets" for information on how to do this.

Issue/Introduction

When processing an inbound EDIFACT document the error, "contains characters not listed in the allowed character set", is seen even though the text content looks correct.What is the cause of thie error message?