IcStart - It gives me the error of "Cannot access message catalog".

IcStart - It gives me the error of "Cannot access message catalog".

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Article ID: KB0086118

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Updated On:

Products Versions
TIBCO BusinessWorks Collaborator -
Not Applicable -

Description

Description:
Description: 
============
On AIX platforms, the server fails to start and displays the error message, "Cannot access message catalog".
Symptoms:
"Cannot access message catalog".


Cause:
This error is caused by the System message catalog environment variables not being set correctly, or the message catalogs are not installed.

Issue/Introduction

IcStart - It gives me the error of "Cannot access message catalog".

Resolution

Resolution:
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There is workaround for this error message.

Set the environment variable NLSPATH, as described in the iIcStart Error Messages. Check the status log for error messages, enter: IcStatusManage -s status_log
If the status log contains a DBMS error code, refer to the DBMS documentation for the interpretation of the error code.

You should set NLSPATH or the equivalent (depending on the flavor of Unix you are using) to /usr/lib/nls/msg/%L/%N:/usr/lib/nls/msg/prime/%N. or NLSPATH $IC_HOME/data/messages and/or LC_MESSAGES En_US

On AIX machines, use locale -a to determine what message catalogs have been installed. Set LC_MESSAGES to a legitimate message catalog identifier (not "C").

Example:

Step 1) % locale -a
   en_US.ISO8859-1
   en_US.IBM-850

Step 2) % setenv LC_MESSAGES en_US

On your PRODUCTION box, change the environmental setting of 'LANG=C'  to  'LANG=en_US'.  Then try 'IcStart -s' on the production box.