In BusinessEvents 3.0.1, clearing the Workitems table when it becomes quite large.

In BusinessEvents 3.0.1, clearing the Workitems table when it becomes quite large.

book

Article ID: KB0090065

calendar_today

Updated On:

Products Versions
TIBCO BusinessEvents Enterprise Edition -
Not Applicable -

Description

Resolution:
Description:
============
In BusinessEvents 3.0.1, clearing the Workitems table when it becomes quite large.

Environment:
==========
TIBCO BusinessEvents 3.0.1
All Operating Systems


Symptoms:
=========
As a RULE_ADMINISTRATOR, there should have three action options (Approve, Unload, and Eject) to choose, but only the Eject option is available.

Cause:
=====
It can be because of one or more of the following points.

1). When Workitems table becomes quite large.

2). When there is an issue in Berkeley Database file(bdb) or it gets corrupted.



Resolution:
==========

1). User can clear the Berkeley database file (.bdb file) and restart the RMS server.But all the Decision tables that are related to the virtual rule functions are lost. Although all the data is stored in the *.impl files, but there is no decision table displayed in Decision Manager.
  
2). Instead of implementing all of the decision tables after clearing the bdb file, users can do the following:
  
- Checkout the project with Original bdb file.              
- Shutdown RMS and clear bdb file.              
- Open the Decision Manager and open the local copy of the project.            
- Start the RMS and login to RMS.(Don't checkout any project).  
- Commit all the tables to RMS. (This will allow bdb to have information about project).              
The Worklist table will become empty and will not reference any old data as bdb is new.

Issue/Introduction

In BusinessEvents 3.0.1, clearing the Workitems table when it becomes quite large.