CUSTAUDIT commands may not work if invoked on a Start Step when using TIBCO iProcess Server Objects or TIBCO iProcess Workspace (Browser).

CUSTAUDIT commands may not work if invoked on a Start Step when using TIBCO iProcess Server Objects or TIBCO iProcess Workspace (Browser).

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Article ID: KB0089428

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Updated On:

Products Versions
TIBCO iProcess Engine (Oracle) -
Not Applicable -

Description

Resolution:
Description:
============
CUSTAUDIT commands may not work if invoked from a start step. The problem may occur under the following scenario:

CUSTAUDIT commands are defined to be invoked on the first step of a TIBCO iProcess procedure.

The case is being started using TIBCO iProcess Server Objects or TIBCO iProcess Workspace (Browser).

The Addressee of the first step is defined as the user starting the case.

Environment:
==========
All supported TIBCO iProcess Engine (iPE) versions 11.1.1.x and 11.1.2.
All supported iPE operating systems and databases.
All supported versions of TIBCO iProcess Server Objects or TIBCO iProcess  Workspace (Browser).

Symptoms:
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The CUSTAUDIT command will appear to have been invoked correctly. However, on inspection of the case audit trail no entry will be seen. There will be no entry of failure in the iPE logs, sw_warn.log or sw_error.log.

Cause:
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The cause of the problem is the result of the case start message and CUSTAUDIT message being processed out of order.  Part of the processing of the CUSTAUDIT is to verify the case number. If the case start has not been processed the validation fails and the CUSTAUDIT fails to process.

Resolution:
=========
This issue is under investigation by TIBCO Engineering. Possible workarounds include:

1). Delay the CUSTAUDIT call, perhaps just record the CUSTAUDIT details in a field and process them at the next step.
2). Define the starter for the first step to be a group rather than the starter being the addressee.

Note:
Check the Release Notes of future versions of the product to see if this issue was addressed in a fix.

Issue/Introduction

CUSTAUDIT commands may not work if invoked on a Start Step when using TIBCO iProcess Server Objects or TIBCO iProcess Workspace (Browser).