JMX settings do not work when BW application is installed as a Windows service.

JMX settings do not work when BW application is installed as a Windows service.

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Article ID: KB0089429

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Updated On:

Products Versions
TIBCO ActiveMatrix BusinessWorks -
Not Applicable -

Description

Resolution:
Description:
============
The following properties were added in an application .tra file. The BW engine was restared from the Administraor GUI. Unable to connect the engine using the JMX tool (JConsole etc.) Everything runs normally if the BW engine is started through the command line.

java.property.com.sun.management.jmxremote=true
java.property.com.sun.management.jmxremote.port=8886
java.property.com.sun.management.jmxremote.authenticate=false
java.property.com.sun.management.jmxremote.ssl=false

Environment:
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TIBCO BusinessWorks : ALL

Cause:
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When a BW application is installed as Windows service, some of the configuration will be cached in the registry. This is why restarting cannot enable the JMX settings.

Resolution:
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Re-installing the Windows service will resolve the problem. To re-install the service, run the following commands from the console.

*************
BW_HOME\bwengine.exe --uninstall --propFile DOMAIN_HOME\application\&ltapp-name>\&ltapp>.tra

BW_HOME\bwengine.exe --install --propFile DOMAIN_HOME\application\&ltapp-name>\&ltapp>.tra
*************

Issue/Introduction

JMX settings do not work when BW application is installed as a Windows service.