TIBCO Enterprise Message Service (EMS) server starts correctly from the command line but when starting the server as a Windows NT service with the same config file, the server fails to start.

book

Article ID: KB0089403

calendar_today

Updated On:

Products Versions
TIBCO Enterprise Message Service -
Not Applicable -

Description

Resolution:
Description:
----------------

The dbstore_classpath has been set in the tibemsd.conf as follows:

dbstore_classpath       = C://tibco/components/eclipse/plugins/com.tibco.tpcl.org.hibernate_3.2.5.001/hibernate3.jar;C://tibco/components/eclipse/plugins/com.tibco.tpcl.org.com.mchange.c3p0_0.9.1.001/c3p0-0.9.1.jar;C:\tibco\ems\5.1\bin\antlr-2.7.6.jar;C:\tibco\ems\5.1\bin\asm-attrs.jar;C:\tibco\ems\5.1\bin\asm.jar;C:\tibco\ems\5.1\bin\cglib-2.1.3.jar;C:\tibco\ems\5.1\bin\commons-collections-2.1.1.jar;C:\tibco\ems\5.1\bin\commons-logging-1.0.4.jar;C:\tibco\ems\5.1\bin\dom4j-1.6.1.jar;ehcache-1.2.3.jar;jta.jar;C:\sqljdbc_2.0\enu\sqljdbc4.jar

All other configurations are fine. While starting the EMS server from the command line at C:\tibco\ems\x.x\bin with the same config file, the EMS server starts correctly. However, when the EMS server is configured as a Window service, it fails to start with the same config file.

Environment:
-----------------

1).  TIBCO Enterprise Message Service – 5.x+
2).  Microsoft Windows


Symptoms:
---------------

The following messages are seen in the EMS server log:

2010-05-16 14:35:18.479 java.lang.NoClassDefFoundError: javax/transaction/Synchronization :
:
2010-05-16 14:35:18.480 SEVERE ERROR: Unable to open store [$sys.failsafe]: [ ESTATUS = 230, ERRSTR = java.lang.NoClassDefFoundError: javax/transaction/Synchronization ]
2010-05-16 14:35:18.571 ERROR: Initialization failed: storage for '$sys.failsafe' not found.
2010-05-16 14:35:18.572 FATAL: Exception in startup, exiting.


Cause:
--------

As per the configuration, ehcache-1.2.3.jar and jta.jar are pointing at the current directory and are required to start EMS server using a database store. These two jar files are located at C:\tibco\ems\x.x\bin directory. When the EMS server is started from command line from C:\tibco\ems\x.x\bin, the EMS server finds them in the current directory and loads them. But while starting as a Windows service, the EMS server cannot find those files in the current directory as there is no absolute path for those two jar files.

Resolution:
--------------

Set the absolute PATH for these two jar files in the main config file of the EMS server.

Issue/Introduction

TIBCO Enterprise Message Service (EMS) server starts correctly from the command line but when starting the server as a Windows NT service with the same config file, the server fails to start.