In TIBCO BusinessEvents 4.0.1, TIBCO BusinessEvents Monitoring and Management (BEMM) dashboard is not showing metrics of the started Business Events(BE) engines.

In TIBCO BusinessEvents 4.0.1, TIBCO BusinessEvents Monitoring and Management (BEMM) dashboard is not showing metrics of the started Business Events(BE) engines.

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Article ID: KB0094270

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Updated On:

Products Versions
TIBCO BusinessEvents Enterprise Edition -
Not Applicable -

Description

Resolution:
Description:
============
In TIBCO BusinessEvents 4.0.1, TIBCO BusinessEvents Monitoring and Management (BEMM) dashboard is not showing metrics of the started Business Events(BE) engines.



Environment:
==========
TIBCO BusinessEvents 4.0.1
TIBCO BusinessEvents Monitoring and Management (BEMM)


Symptoms:
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1).  BEMM Dashboard does not show metrics of started engines.

2).  BEMM broker log displays the following message -
   "Failed to establish health pinger for XXX, marking it as inactive and critical..."


Cause:
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This is due to the SSL JMX property being set as "true" in the TRA files of the started engines.


Resolution:
==========
Comment the the following property in tra file of BE engine ->

  java.property.com.sun.management.jmxremote.ssl=false

Issue/Introduction

In TIBCO BusinessEvents 4.0.1, TIBCO BusinessEvents Monitoring and Management (BEMM) dashboard is not showing metrics of the started Business Events(BE) engines.