Products | Versions |
---|---|
TIBCO BusinessConnect | - |
Not Applicable | - |
Resolution:
Description:
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After prolonged operation of the BusinessConnect (BC) engine, the engine goes into an "error" state even though it is running and processing transactions. How do I restore the state of the engine to "running"?
Environment:
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TIBCO BusinessConnect Protocol 5.X.X all versions
Cause:
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The BC engine is going into an "error" state because of a bad message being received by a BW process starter within the BC engine. This bad message was received as part of a bad message being processed beyond the sync response wait time and is being rejected by EDI to be processed. While it does not impact the operation of the BC engine, it does cause the engine to go into an error state.
Resolution:
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To restore the "running" state of the engine, use the Hawk console or the BC engine tracing message to find the job that has the error in the engine and kill it. Killing the process will not impact the operation of the engine and will restore the engine to a "running" state.