Losing Events created in the RTC during EMS reconnect period.

Losing Events created in the RTC during EMS reconnect period.

book

Article ID: KB0084590

calendar_today

Updated On:

Products Versions
TIBCO BusinessEvents Enterprise Edition -
Not Applicable -

Description

Resolution:
Description:
===========

Losing Events created in the RTC during EMS reconnect period.

Environment:
===========
BusinessEvents 3.0.2
All Operating Systems

Symptoms:
=========
PostRTC thread tries to send the Event created in the RTC 10 times only. The retry count and delay is hardcoded and could not be changed. The logfile shows the error
"Post RTC error java.lang.RuntimeException: Action failed even after 10 attempts. Giving up." The Event is then lost.

Cause:
======
Configuration issue.

Resolution:
=========
Add the following property to the TRA file and make sure that the values for reconnect count and delay are large enough to handle the EMS downtime.

java.property.com.tibco.tibjms.connect.attempts &ltreconnectCount>,&ltdelayInMilliSecs>

Example:
java.property.com.tibco.tibjms.connect.attempts 1000,2000
(1000 connect attempts at intervals of 2 seconds)

NOTE:
1.) The property "be.jms.reconnect.timeout=&ltnon-zero value in sec>" does not help. You will lose the new Event when the EMS server is not available within the 10 retries of the PostRTC.

2.) "java.property.com.tibco.tibjms.connect.attempts" is used when TRA file includes both properties "java.property.com.tibco.tibjms.connect.attempts" and "be.jms.reconnect.timeout"

Issue/Introduction

Losing Events created in the RTC during EMS reconnect period.