Products | Versions |
---|---|
TIBCO BusinessConnect | - |
Not Applicable | - |
Resolution:
Description:
============
In a multi-engine BusinessConnect (BC) 5.3.X environment, the BC instance stops generating outbound batch transactions. Transaction are still added into the batch queue for outbound transmission, but the batch never gets generated.
Environment:
==========
TIBCO BusinessConnect Protocol 5.X.X.6.X.X all versions.
Symptoms
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In reviewing the BusinessConnect*.logs for the interior server, no poller processing is seenl. No change is observed if all the engines are stopped and restarted.
Cause:
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BC 5.3.X implements a new engine synchronization mechanism that uses a file lock in the shared directory among the BC engines. Sometimes, the file associated with this lock becomes corrupted.
Resolution:
=========
1). Stop all engines in your BC environment.