Resolution: Description:
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In a multi-engine BusinessConnect (BC) 5.3.X environment, the BC instance stops generating outbound batch transactions. Transaction are still added into the batch queue for outbound transmission, but the batch never gets generated.
Environment:
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TIBCO BusinessConnect Protocol 5.X.X.6.X.X all versions.
Symptoms
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In reviewing the BusinessConnect*.logs for the interior server, no poller processing is seenl. No change is observed if all the engines are stopped and restarted.
Cause:
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BC 5.3.X implements a new engine synchronization mechanism that uses a file lock in the shared directory among the BC engines. Sometimes, the file associated with this lock becomes corrupted.
Resolution:
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1). Stop all engines in your BC environment.
2). Go to the BC_SHARED_DIRECTORY/tibco_bcshare/flock directory and delete the file contained in that directory.
3). Add the property
java.property.bc.useFLock=false to all deployed engine TRA files. If running the BC engines as Windows services, be sure to add this entry to the Windows registry as well for the specific engine(s).
4). Restart the engine.
NOTE: Starting with BusinessConnect 6.2.1, this property is now a part of the Administrator>BusinessConnect>System Settings. Activated Protocol Plug-ins and Properties>BC screen. See the BC 6.2.1 release notes for details.