Products | Versions |
---|---|
TIBCO BusinessEvents Enterprise Edition | - |
Not Applicable | - |
Resolution:
Description:
============
Debug will not start up in Studio. There is usually a message about not being able to connect to JVM. See Symptoms below for more details.
Environment:
==========
TIBCO BusinessEvents (BE) 4.0.1 and 5.0.0 on Windows platforms.
Symptoms:
=========
You may see the following error messages:
"Cannot connect to VM
com.sun.jdi.connect.IllegalConnectorArgumentsException: Not listening
at com.sun.tools.jdi.GenericListeningConnector.stopListening(GenericListeningConnector.java:115)
at com.tibco.cep.studio.debug.core.launch.ApplicationDelegate.launchLocal(Unknown Source)
at com.tibco.cep.studio.debug.core.launch.ApplicationDelegate.launch(Unknown Source)
. . ."
Or
" Error occurred during initialization of VM
Could not reserve enough space for object heap".
Or
"Java HotSpot(TM) Server VM warning: CMS bit map backing store failure
Java HotSpot(TM) Server VM warning: Failed to allocate CMS Bit Map
Error occurred during initialization of VM
Could not create CMS collector
Could not create the Java virtual machine."
Cause:
=====
The memory setting is not correct for Studio.
Resolution:
=========
In BE_HOME\4.0\studio\eclipse\Studio.ini change the heap memory size. First lower -Xms1024m to say 256m. If that does not work then lower -Xmx to 512m. Restart Studio after each change.