When installing the TIBCO ActiveMatrix® Policy Manager (PM) 3.1.0 hotfix (HF) 04 on top of hotfix 03, it encountered the error that the hotfix4 has been installed and could not continue. How to resolve it?

When installing the TIBCO ActiveMatrix® Policy Manager (PM) 3.1.0 hotfix (HF) 04 on top of hotfix 03, it encountered the error that the hotfix4 has been installed and could not continue. How to resolve it?

book

Article ID: KB0094566

calendar_today

Updated On:

Products Versions
TIBCO ActiveMatrix Policy Agent -
Not Applicable -

Description

Resolution:
When installing PM 3.1.0 HF 4 on top of HF3, it reported the “TIBINS5188037: Warning” and the following detailed error, see attached screenshot for more details:
“The following required or selected installation features are already installed on the target system.
Before re-installing these features, please shutdown any TIBCO processes, otherwise errors may occur.
Reinstalling existing features should not be done unless you are explicitly told to do so by TIBCO Support.
TIBCO ActiveMatrix Policy Manager 3.1.0 Hotfix4 – Policy Manager
TIBCO ActiveMatrix Policy Manager 3.1.0 Hotfix4 – Service Grid Plugin Agent
Do you wish to reinstall these features?
Select Yes to reinstall. Select NO to use the currently installed features.
Select CANCEL to exit the installation.”



Environment:
==========
o TIBCO Product name and version:  TIBCO ActiveMatrix® Policy Manager 3.1

o Operating System(s) impacted: Windows

o Java Runtime Environment (JRE): 1.6.0


Symptoms
==========
When encountering this issue, the customer will fail in installing the PM 3.1 HF4.

Cause
==========
This is a known issue and will be fixed in the next release of the hotfix.
Resolution:
=========
Before the issue is resolved, the current workaround is to add  'forceFeatureReinstall="true" ' in the element of customSettings in the pm_FeatureConfig.xml of the Hotfix installer as below:

    &ltcustomSettings disableUninstall="true" installerType="servicepack" machineModel="false" multipleEnvironmentSupport="true" requiredJREVersion="1.5.0,1.6.0" forceFeatureReinstall="true"/>

Issue/Introduction

When installing the TIBCO ActiveMatrix® Policy Manager (PM) 3.1.0 hotfix (HF) 04 on top of hotfix 03, it encountered the error that the hotfix4 has been installed and could not continue. How to resolve it?

Attachments

When installing the TIBCO ActiveMatrix® Policy Manager (PM) 3.1.0 hotfix (HF) 04 on top of hotfix 03, it encountered the error that the hotfix4 has been installed and could not continue. How to resolve it? get_app