book
Article ID: KB0094650
calendar_today
Updated On:
Description
Resolution:
Description:
==========
TIBCO Administrator running for a domain is throwing "ClassNotFoundException: <JDBC_Driver>" in the start up logs. Similar exceptions can be observed in the <TIBCO_HOME>/tra/domain/<Domain_Name>/logs/Administrator.log.
This exception may be seen in the <TIBCO_HOME>/tra/domain/<Domain_Name>/logs/tsm.log file as well, which indicates the issue is with the domain Hawk agent. If you are facing this issue with the domain Hawk agent running on a client machine then it is possible that the software installed on that client machine is not listed/visible on the "Admin GUI > Resource Management > Installed Software" screen.
Generally, the following exception occurs in the following cases:
<<<<<<<<<<<<<<<<<<<<<<<<<<
com.tibco.runtime.pool.ServerNotAvailableException: Server not available at address <DB URL>
.
Caused by: com.tibco.runtime.pool.AllocationException: Connect failed to address: <DB URL> : java.lang.ClassNotFoundException: <JDBC_Driver>
.
Caused by: java.lang.ClassNotFoundException: <JDBC_Driver>
>>>>>>>>>>>>>>>>>>>>>>>>>>
For example:
<<<<<<<<<<<<<<<<<<<<<<<<<<
com.tibco.runtime.pool.ServerNotAvailableException: Server not available at address <DB URL>
.
Caused by: com.tibco.runtime.pool.AllocationException: Connect failed to address: <DB URL> : java.lang.ClassNotFoundException: oracle.jdbc.driver.OracleDriver
.
Caused by: java.lang.ClassNotFoundException: oracle.jdbc.driver.OracleDriver
>>>>>>>>>>>>>>>>>>>>>>>>>>
Sample ClassNotFoundExceptions for different database drivers are given below:
1). Vendor-supplied database driver:
a). Oracle Thin Driver : java.lang.ClassNotFoundException: oracle.jdbc.driver.OracleDriver
b). Microsoft JDBC driver : java.lang.ClassNotFoundException: com.microsoft.sqlserver.jdbc.SQLServerDriver
c). DB2Driver : Java.lang.Classnotfoundexception : com.ibm.db2.jcc.DB2Driver :com.ibm.db2.jcc.DB2Driver
2). DataDirect Drivers:
a). Oracle : java.lang.ClassNotFoundException:tibcosoftwareinc.jdbc.oracle.OracleDriver
b). Microsoft SQL server : java.lang.ClassNotFoundException: tibcosoftwareinc.jdbc.sqlserver.SQLServerDriver
Environment:
==========
OS: All
TIBCO Administrator: 5.7.x, 5.6.x
TIBCO Runtime Agent: 5.7.x, 5.6.x
Domain Repository: DB Based
Cause:
======
Generally, this error indicates a problem with the classpath in the TIBCO domain administrator/hawkagent tra file.
This may happen if:
1). The path to the JDBC drivers is not stated in the domain tra file (tibcoadmin_<Domain_Name>.tra/hawkagent_<Domain_Name>.tra) or if it is, it's incorrect.
2). JDBC drivers are not available on this machine at the specified path.
If you are seeing this error with TIBCO Administrator running for a domain then check the "tibco.class.path.extended" variable in the <TIBCO_HOME>/administrator/domain/<Domain_Name>/bin/tibcoadmin_<Domain_Name>.tra file.
Similarly, for the domain Hawk agent, check the "tibco.class.path.extended" variable in the hawagent_<Domain_Name>.tra file located at <TIBCO_HOME>/tra/domain/<Domain_Name>/
Workaround:
==========
- Vendor-supplied database driver:
************************
Run the traDBConfig utility to update the domain tra files in order to configure a supported vendor-supplied database driver.
Sample commands to modify domain tra files:
1). To modify tibcoadmin_<Domain_Name>.tra:
traDBConfig -type OracleThin -dbPath <path>/ojdbc<version>.jar -path <TIBCO_HOME>/administrator/domain/<domain-name>/bin/tibcoadmin_<Domain_Name>.tra
2). To modify Hawk agent_<Domain_Name>.tra:
traDBConfig -type OracleThin -dbPath <path>/ojdbc<version>.jar -path <TIBCO_HOME>/tra/domain/<domain-name>/Hawkagent_<Domain_Name>.tra
The traDBConfig utility is available at <TIBCO_HOME>/tra/<version>/bin. Refer to the "TIBCO Runtime Agent documentation: Installation > Installed Components > traDBConfig Utility" for more details.
Alternatively, you can also place these drivers in <TIBCO_HOME>/tpcl/<version>/jdbc. Since this location is already added to the classpaths of tibcoadmin_<Domain_Name>.tra and Hawkagent_<Domain_Name>.tra you do not need to run traDBConfig .
Once done, restart the TIBCO domain Administrator/Hawk agent and confirm that the issue is resolved.
- DataDirect Drivers:
*************
If you are seeing this issue with DataDirect Drivers, then check if they are available under the <TIBCO_HOME>/tpcl/<version>/jdbc directory. If there is no "jdbc" directory then you may have to install these drivers. This happens with TIBCO Runtime Agent 5.7.x. Note that TIBCO no longer bundles the DataDirect JDBC Driver with TIBCO Runtime Agent 5.7.x. As a result, these JDBC drivers are not present in the installation.
Try the latest DataDirect drivers. (Refer to KB:
34995 entitled, "How to obtain the DataDirect JDBC Driver with TIBCO Runtime Agent (TRA) 5.7.x ?" for details on how to the drivers for TIBCO Runtime Agent 5.7.x.) When installed, these DataDirect drivers will be placed under TIBCO_HOME\tpcl\5.7. Once done, restart the TIBCO domain Administrator/Hawk agent and confirm that the issue has been resolved.
On Windows server:
************************
After running traDBConfig you will need to run the following cmds to update the Windows services for TIBCO Admin and Hawkagent for the domain. These cmds will update the Windows registry parameters for these two services from the tibcoadmin_<domain name>.tra file and hawkagent_<domain name>.tra file.
tibcoadmin_<domain name>.exe --update
hawkagent_<domain name>.exe --update
You can find help for this cmd using - tibcoadmin_<domain name>.exe --help
Issue/Introduction
TIBCO Administrator server is throwing "ClassNotFoundException: ;JDBC_Driver;" in the start up logs. Similar exceptions can be observed in the Administrator.log and/or tsm.log.
Additional Information
TIBCO Runtime Agent documentation.