Resolution: Description:
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When a TIBCO BusinessWorks (BW) process tries connecting to a Web Service, it returns the error, "iaik.security.ssl.SSLException: Server certificate rejected by ChainVerifier".
Environment:
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Operating System(s): All
TIBCO Product(s): TIBCO BusinessWorks
TIBCO Designer
TIBCO Administrator
Cause:
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When connecting to a Web Service the BW process(es) authenticates the web service server's certificate. As part of the authentication, all certificates from the server to the Certificate Authority (root cert) will need to be confirmed. Typically, this error happens when a certificate in the chain cannot be confirmed either because it is missing or is incorrect. Note that the same error can happen if a certificate is missing or incorrect on the the client side. For example, if the BW process(es) needs to connect to the web service server via a proxy server. It will also be required to have the proxy server certificate in it's trust store.
Resolution:
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Check that you have all the required certificates and that they are up to date. The certificates can be checked either by using third party applications, Internet Explorer or Portecle.
Instructions for Internet Explorer 8
-Go to the <web service address> in the browser
-Menu bar-> View-> Security Report-> View Certificates-> Certification Path
Instructions for Portecle
-Menu bar-> Examine-> Examine SSL/TLS connections-> <Web service address>
Refer to the third party application's website for further information on usage.