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Article ID: KB0094640
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Updated On:
Description
Resolution:
Description:
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If the SW_WISINST attribute has been defined as numeric as stated in the TIBCO iProcess™ Engine Administrator’s Guide, how is the value removed if the configuration is no longer required?
Environment:
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All supported TIBCO iProcess Engines.
All supported operating systems and databases.
Cause:
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The problem is caused because the attribute is defined as a numeric. The TIBCO iProcess Administrator User Manager will not allow numeric values to be set as a space or blank value.
Resolution:
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There are two options available to resolve the issue.
Option 1.
The first option is to set the SW_WISINST attribute value to 0 (zero). This acts as if the value is blank as there is no WIS with a process instance of 0.
Option 2.
The second option is to use the swutil utility and supply a control file to update the attribute value. The example below details attribute values for “queue01” which has been configured to use WIS 8.
G+queue01
V+ queue01,DESCRIPTION,queue01
V+ queue01,LANGUAGE,English
V+ queue01,MENUNAME,SW_GROUP
V+ queue01,QSUPERVISORS,
V+ queue01,SORTMAIL,PROCEDURE
V+ queue01,SW_DOMAIN,
V+ queue01,SW_WISINST,8
V+ queue01,USERFLAGS,
V+ queue01,WISCACHE,
The following control file could be created to set the value to blank:
V+queue01,SW_WISINST,
Using the following commands would update the value to blank.
SWDIR\bin\swutil USERINFO c:\<control_file_directory_and _name>
(this is assuming the control file is on drive C:)
SWDIR\bin\swutil MOVESYSINFO
A restart of the TIBCO iProcess Engine would be required for the change to take effect for either option.
References:
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TIBCO iProcess™ swutil and swbatch Reference Guide.
TIBCO iProcess™ Engine Administrator’s Guide.
Issue/Introduction
Deleting the SW_WISINST attribute once it has been set.