TIBCO BusinessEvents Studio hangs and becomes unresponsive.

TIBCO BusinessEvents Studio hangs and becomes unresponsive.

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Article ID: KB0084861

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Updated On:

Products Versions
TIBCO BusinessEvents Enterprise Edition -
Not Applicable -

Description

Resolution:
Description:
============
You never get a chance to select a workspace directory.  If you look at the Windows task manager Studio is listed as unresponsive.  In the .log file in the workspace directory the following error stack was present:
!ENTRY org.eclipse.core.resources 2 10035 2011-08-31 14:33:54.599
!MESSAGE The workspace exited with unsaved changes in the previous session; refreshing workspace to recover changes.
!SESSION 2011-09-16 15:00:16.599 -----------------------------------------------
eclipse.buildId=M20090211-1700
java.version=1.6.0_20
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=en_US
Command-line arguments:  -os win32 -ws win32 -arch x86

!ENTRY org.eclipse.core.resources 2 10035 2011-09-16 15:00:35.131


Environment:
==========
Windows

Cause:
=====

The workspace is corrupt and a new workspace directory must be given. You can use the following command line to give a new workspace, 'studio.exe –data C:\workspace'.  
To make this permanent change the studio.ini, which is found in

BE_HOME\4.0\studio\eclipse, and add
-data
C:\workspace

before the –vmargs.  See attached resolution document as an example.

Issue/Introduction

TIBCO BusinessEvents Studio hangs and becomes unresponsive.

Attachments

TIBCO BusinessEvents Studio hangs and becomes unresponsive. get_app