Using TIBCO BusinessEvents Decision Manager to import domain model in decision table, it throws"Access denied to create domain model" error.

book

Article ID: KB0084832

calendar_today

Updated On:

Products Versions
TIBCO BusinessEvents Enterprise Edition -
Not Applicable -

Description

Resolution:
Description:
=========
Using TIBCO BusinessEvents Decision Manager  to import domain model in decision table,it throws"Access denied to create domain model" error .

Environment:
===========
BusinessEvents 5.0.0
All Operating Systems

Symptoms:
=========
When admin user tries to import domain model using decision manager studio, the following error is thrown:

"Access denied to create domain model".

Cause:
======
By default decision manager is the given business user role and hence has limited access. After setting the -DACTIVATE_BUSINESS_USER=false, the user should be able  to import the domain.

Resolution:
=========
Configure the setting  -DACTIVATE_BUSINESS_USER=false in the decisionmanager.ini file and restart the decision manager. This would make the decision manager have the   administrator role , which means more of the menus are enabled  similar to a BusinessEvents studio.

Issue/Introduction

Using TIBCO BusinessEvents Decision Manager to import domain model in decision table, it throws"Access denied to create domain model" error.