Addressing timeouts caused by a firewall sitting between a TIBCO Collaborative Information Manager (CIM) server and an Oracle database companion.

Addressing timeouts caused by a firewall sitting between a TIBCO Collaborative Information Manager (CIM) server and an Oracle database companion.

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Article ID: KB0094617

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Updated On:

Products Versions
TIBCO Collaborative Information Manager -
Not Applicable -

Description

Resolution:
Description:
============
Addressing timeouts caused by firewalls sitting between a TIBCO Collaborative Information Manager (CIM) server and an Oracle database companion.

Environment:
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TIBCO Collaborative Information manager (CIM) 8.0.1 / 8.2.1 and TIBCO Master Data Management (MDM) / 8.3.0 Server located on one server and an Oracle database located on another. Firewalls exist between the servers.

Symptoms
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When CIM is left to idle for an extended period of time, the connection between the CIM and the Oracle Database unexpectedly closes.

Cause
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Firewalls sitting between a CIM server and an ORACLE DB companion are timing out network connections due to inactivity, leading to the connection between the CIM server and an ORACLE DB companion being broken.

Resolution
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If timeouts caused by firewalls sitting between a CIM server and an ORACLE DB companion are causing connection timeout issues, then the SQLNET EXPIRE_TIME parameter can be set to a value less than the shortest expire time set for the firewalls between the CIM and the DB. The EXPIRE_TIME parameter causes the ORACLE DB SERVER to check if a connection is dead, but as a side effect it causes enough network traffic to keep any firewall "en-route" happy that the connection is alive. Network Administrators normally set timeouts on firewalls to prevent denial of service attacks, but using ORACLE this way is a valid use and is the recommended way from ORACLE for keeping connections open across firewalls between the ORACLE server and any other dependent server.

This parameter needs to be set in the SQLNET.ORA file for the CIM database (in the directory $ORACLE_HOME/network/admin), which will end up looking something like the following (exact values will vary according to the installation):

NAMES.DIRECTORY_PATH= (LDAP, TNSNAMES, HOSTNAME, EZCONNECT)
...
SQLNET.EXPIRE_TIME = 25

In this case SQLNET.EXPIRE_TME has been set to 25 minutes. This connection must be set on the ORACLE server. It enables dead connection detection, that is, after the specified time (in minutes) the server checks if the client is still connected and if not, the server process exits. Note that the database server needs to be restarted after the above change for it to take effect.


Issue/Introduction

Addressing timeouts caused by a firewall sitting between a TIBCO Collaborative Information Manager (CIM) server and an Oracle database companion.

Additional Information

See http://docs.oracle.com/cd/E11882_01/network.112/e10835/sqlnet.htm#i500318 for more details on this, and other parameters.