How do I specify reserved characters in URL when posting messages to BusinessConnect?

How do I specify reserved characters in URL when posting messages to BusinessConnect?

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Article ID: KB0084755

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Updated On:

Products Versions
TIBCO BusinessConnect -
Not Applicable -

Description

Resolution:
Description:
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As an example, an inbound transaction has an operationID 'BC/1.0/Notify' contains a forward slash (/), a reserved character.  When BC gets an inbound message with URI '/dmz/EZComm/?fromTp=Seller&toTP=Buyer&operationID=BC/1.0/Notify', BC throws the following error:

“Runtime Extension for protocol Notify not found. Please check your outbound Transport URL configuration”

Environment:
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BusinessConnect 6.x versions

Symptoms:
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BC log generates this error “Runtime Extension for protocol Notify not found. Please check your outbound Transport URL configuration”

The message is send to Lost and Found.

Cause:
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Forword slash (/) is a reserved character for URLs.  URLs use some characters for special use in defining their syntax. When these characters are not used in their special role inside a URL they need to be encoded with hex values. URL encoding of a hex character consists of adding the "%" symbol followed by the two-digit hexadecimal representation (case-insensitive).

Resolution:
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'BC/1.0/Notify' should be changed 'BC%2F1.0%2F/Notify'.

Complete URL should be:
'/dmz/EZComm/?fromTp=Seller&toTP=Buyer&operationID=BC%2F1.0%2F/Notify'

Issue/Introduction

How do I specify reserved characters in URL when posting messages to BusinessConnect?