TIBCO BusinessEvents (BE) Rules do not get triggered or do not trigger occassionally when an event is received.

TIBCO BusinessEvents (BE) Rules do not get triggered or do not trigger occassionally when an event is received.

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Article ID: KB0094468

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Updated On:

Products Versions
TIBCO BusinessEvents Enterprise Edition -
Not Applicable -

Description

Resolution:
Description:
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BE rules do not get triggered or do not trigger occassionally when an event is received by the BE engine.


Environment:
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All Operating systems.
TIBCO BusinessEvents version 3.x / 4.x and 5.x


Symptoms:
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BE inference agents does not trigger any rules or it does not trigger rules occasionally when an event is received.


Cause:
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This can be caused by various reasons listed below in the Resolution. Check your project implementation and the logs for further clues to decide which matches your condition.


Resolution:
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1). If the inference agent logs have entries such as "Attempt to assert .. extId=xxx" while extId already exists. This is due to the fact that you are trying to assert an event with the same extid (duplicated in another event / concept).

2). If the rule does not always trigger then make sure that the channel paired with this event is enabled.

3). In some use cases, the duplicate extID errors might be thrown due to improper locking in the create/read/delete logic of an event or concept. Make sure you follow the guideline in the TIBCO BusinessEvents manual on Locking mechanisms when accessing an object. This is explained better in the TIBCO BusinessEvents 4.0.1 and 5.x manuals which you can refer to online at http://docs.tibco.com .



References:
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http://docs.tibco.com

Issue/Introduction

TIBCO BusinessEvents (BE) Rules do not get triggered or do not trigger occassionally when an event is received.