Resolution: Description:
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While configuring a set of rules as a WebService, DeployDS.cmd fails with ‘Connection Reset’ exception.
Environment:
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TIBCO iProcess Decisions Server v4.1.2 / v4.1.1 / v4.0.1
Symptoms:
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While using DeployDS.cmd to configure a set of rules as a WebService, the following error is observed:
"Exception:: java.net.SocketException: Connection reset"
Cause:
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1). Tomcat server is not running.
2). Axis Service is not configured on the Tomcat server.
3). Axis Admin Client API, by default, points to port number 8080. If the Tomcat Port number is not 8080, this exception can be observed.
Resolution:
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1). StarT the TOMCAT server using the shortcut installed by decisions server. All Programs -> TIBCO iProcess Decisions <version> -> TIBCO iProcess Decisions Server -> Start Server (Tomcat).
2). If Axis is correctly setup and running in the tomcat server, then while accessing http://<Tomcat_Host>:<Tomcat_Port#>/axis/services/Corticon, the response should be, “Corticon Hi there, this is an AXIS service!”.
The default installation of iProcess Decisions Server would install the Tomcat Server and set up the axis services ( at \TIBCO\iProcess Decisions\Apache\webapps\axis).
3). The following configuration change needs to be done in the DeployDS.cmd (-l attribute is added) –
Change the line from:
<JDK_HOME>\bin\Java.exe org.apache.axis.client.AdminClient DeployDS.wsdd
To:
<JDK_HOME>\bin \Java.exe org.apache.axis.client.AdminClient -l http://<TomcatHostname>:<TomcatPort#>/axis/services/AdminService DeployDS.wsdd
References:
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http://ws.apache.org/axis/java/install.html